BF1 Issues With Random Disconnects From Server - Resolved

#1
Image


My issues with Battlefield 1 randomly disconnecting me from a session "game" started today. I could play for several minutes and with no warning I would see the loading icon start spinning and it would disconnect me from the game immediately and put me back at the main BF1 screen. No error messages or disconnect messages just straight back to main BF1 startup screen.

I looked at lots of posts but nothing noteworthy on trying as this just started for me today and I assumed it was perhaps network related on the EA or Origin network side and would clear up. It didn't. All day and evening long it repeated. Tested my connection and all came back fine.

I decided to have a close look at my network adapter settings. That's > Control Panel\Network and Internet\Network Connections for me on WIN 7. Right click on your active connection > Configure > Advanced tab. Make sure "Energy Efficient Ethernet" and "Green Ethernet" are both disabled.

I know I had these intentionally disabled before due to those settings having a tendency to cause time-outs and/or connection interruptions for me before on some web applications while working for long periods of time in a web work session.

Anyways it has worked for me. The disconnects have ceased and I'm able to stay in game now as I was before all this started today. Maybe worth giving a shot if you are having connection issues. Please post if it does work for you as well .

Who is online

Users browsing this forum: No registered users and 1 guest

cron